Super - Settlements processing degraded – Incident details

All systems operational

Settlements processing degraded

Resolved
Major outage
Started about 1 year agoLasted about 2 hours
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    An incident with one of our third parties has affected settlements for some merchants. The third party has resolved their incident. We are monitoring our systems for any further issues.