Super Website Maintenance
Scheduled for April 14, 2023 at 4:50 AM – 5:19 AM
Affects
Website
Under maintenance from 4:50 AM to 5:19 AM
Completed
April 14, 2023 at 5:19 AMCompleted
April 14, 2023 at 5:19 AMMaintenance has completed successfully.
In progress
April 14, 2023 at 4:50 AMIn progress
April 14, 2023 at 4:50 AMMaintenance is now in progress.
Planned
April 14, 2023 at 4:50 AMPlanned
April 14, 2023 at 4:50 AMWe are planning for a scheduled maintenance on Super's website infrastructure.
During this time the following may be affected.
- superpayments.com
- superpayments.co.uk